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Spirent TestCenter: 5.24 - C50 long ethernet runs to the administration port may cause the GUI to lock up

Symptoms

One of our customers found this particular issue after they sent in a purchased C50 to 6GHz upgrade 

The customer stated they did not have this problem before the 6GHz upgrade to their C50 nor when using a demo unit, even when using long ethernet runs

 
ISSUEONLY when using a long ethernet runs to the administration port, the GUI hangs after running a single b2b test on the ethernet ports, if the customer runs the same exact test with the PC (Where STC is running) near to the C50, the test goes just fine. Logs sometimes shows network link disconnected:
 
2021-08-21T07:51:17.763Z ERROR 14676    - fmwk.bll.core.utils  - System Event: level = WARN, source = e1dexpress, date = Fri Aug 13 13:33:49 2021
message = Intel(R) Ethernet Connection (7) I219-LM
Network link is disconnected.

  
From the customer:
I have two RJ45 wall jacks that run from where the PCs are located to two wall jacks near C50 in a different room.  Given the findings of the prior test, I replaced the patch cords in both rooms with brand new patch cords.  One of the Ethernet runs is used to connect the PC to the C50 admin port, the other is used to connect the PC to the LAN port of the DUT so I can monitor the DUT.  Both of these runs are rather long, but I believe they are in spec (less than 100 meters).
I ran my original Wifi test, 2Gb/s 1518 byte UDP traffic from a 10GbE C50 Ethernet port thru the DUT to the 6GHz 4x4 client on the C50 using the newer PC.  It failed after several hours (GUI hang again).  Then I swapped the connections for the C50 admin port and DUT LAN port so I was using the second structured wiring run.  I ran the test and it failed the same way after several hours.
I realized that for the longest time, I had been using an old Cisco Gigabit switch near the C50 since I had a second demo C50 and only one Ethernet connection for both C50's.
I ended up putting it back, taking the admin connection from the C50 into one port of the switch and the wall jack patch cord to a second port.  I restarted the test and it has been running error free for over 24 hours.
 
Environment
 
  • C50
  • C50-KIT-11AX-8
  • STC 5.23
  • STC 5.24

Steps to reproduce:
 
The customer is able to reproduce this issue everytime if they use a long ethernet run, this issue happens when running the ethernet ports b2b:
  • The way the customer is running it:
    • Configuration customer uses: Loopback.tcc (Find attached)
    • The customer brings up WiFi ports (1/1 through 1/6) however those ports are not used, they are just UP on the configuration.
      • I'm not sure if having these WiFi ports available on the configuration makes the difference or not
    • Port 1/7 is directly connected to port 1/9
    • Port 1/8 is directly connected to port 1/10
 The issue is not reproducible in-house, I have tested the same C50 model as the customer and the same release/configuration, and the test completed +3 days without any issue, most likely the ethernet run is different (We used the already established lab setup in Calabasas Support Lab)
(5.24 release / C50-KIT-11AX-8 / Same configuration as customer / ports b2b – 7->9 and 8->10)
 
Explanation/Resolution

CR Raised:
  • CR-01512926  
  • CIPCD-17288
 
Root Cause

This issue happen due to "as designed" event. When the management port drops/flaps the test ports are taken down. The customer put a switch between the mgt port and C50 and the link does not drop hence the test ports remain up. This appears to be the work-around going forward.
 
Attachments
Attachment

Product : Spirent TestCenter,C50R_CONTROLLER