Printer FriendlyEmail Article Link

Which version of TCL do I use when running legacy Avalanche Automation? (pre 4.10 Avalanche release)

Environment/Versions
2.x,3.x,4.0x
Answer

Legacy Avalanche API requires Active State TCL version 8.4.13

Avalanche requires TCL to be in place for converting GUI test into TCL scripts.

If you are performing an upgrade chances are you have TCL already installed. Searching your system for TCLSH84.EXE will provide you with the location that the Avalanche GUI requires for initialization.
Default location example for 3.90: C:\Program Files\Spirent Communications\Spirent TestCenter 3.90\TCL\bin

If you have not installed TCL it can be download from http://support.spirent.com -> log in and go to -> downloads -> Spirent Test Center -> TCL 8.4.13 (configured for Spirent TestCenter Automation)
Alternate location may include Downloads -> Archived Releases -> Spirent TestCenter & Avalanche

Please note as of the 4.10 release a new API was introduced using Active State TCL 8.5.11 which may be downloaded directly from the Active State website.


Product : Avalanche,Automation,Avalanche