Printer FriendlyEmail Article Link

Spirent TestCenter: LACP test crashing with error: Fault ocurred when communicating with port XX Please reboot equipment and/or restart application.

Symptoms

LACP test is crashing with following error after Start Capture on all ports:
 
18/04/11 15:52:02.610 FATAL 140457130243840 - user.rpc             - Fault occurred when communicating with port //172.25.48.109/2/6.  Please reboot equipment and/or restart application. Capture_2.SetCaptureCtrl returned Internal error: CapCtTxBase::SetOutGoingLoopBack: sysctl dev..tx_loopback = 0 returned 2
18/04/11 15:52:02.610 INFO  140457130243840 - fmwk.bll.base.msg    - Disconnect session 1

 
Environment
 
  • STC 4.85
  • FX2-40G-Q5 (10G mode)
  • 8 ports in total:
    • 4 ports in LAG
    • 4 ports outside a LAG
  • STC-40G-PortGroup-1X5-Port profile
How to replicate the issue?:
  1. Activate STC-40G-PortGroup-1X5-Port profile on FX2-40G-Q5 test module
  2. Reserve 8 ports on this way:
    • 4 ports in same LAG
    • 4 ports outside a LAG
  3. Start LACP from:
    1. Go to Lag (Same section as all the ports)
    2. Go to Member Ports section
    3. Select all ports under LACP tab
    4. Start LACP using Start button (at the top)
  1. Wait untill LACP stat is UP
  2. Start Traffic
  3. Start Capture on all the ports (Toolbar - Start Capture on all the ports button)
  4. Then you will see the test crashes:
 


 
Explanation/Resolution
 
  • The issue is resolved on 5.18 release (January 2021 release)
 
  • Workaround:
    • Change profile to STC-Multiport on test module (Instead of 1x5 profile)
Root Cause
 
  • Bug

Product : Spirent TestCenter,LACP,Capture,Packet Captures,FX2